Конвертация Excel файла в MXL

Публикация № 1064229

Разработка - Обработки - Универсальные обработки

Excel mxl Конвертер 1С8 xlsx

7
Простейший конвертор файлов Excel в MXL. Когда заказали отчет, а лень его рисовать. Поддерживает xls и xlsx. Те, кому лень писать, можете скачать ниже:

Инструкция:

1 Открываем обработку (в зависимости от версии толстый или тонкий клиент)

2 В форме выбираем Excel файл для конвертации

3. Нажимаем кнопку конвертировать и получаем печатную форму mxl, на базе которого можно писать отчеты

Проверялась на конфигурации ЗУП КОРП, редакция 2.5 (2.5.140.1) 

Работает на всех конфигурациях.

Код ниже:

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
КонецПроцедуры


&НаКлиенте

Процедура КнопкаСформироватьНажатие(Кнопка)
	ТабличныйДокумент=ПодготовитьТаблицуСДанными(объект.Файл);
	ТабличныйДокумент.Показать();

КонецПроцедуры

&НаСервере
Функция ПодготовитьТаблицуСДанными(Файл)
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	Попытка
		ТабличныйДокумент.Прочитать(Файл, СпособЧтенияЗначенийТабличногоДокумента.Текст);
	Исключение
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = ОписаниеОшибки();
		Сообщение.Сообщить();
	КонецПопытки;	
  возврат ТабличныйДокумент;	
	
	
КонецФункции

&НаКлиенте
Процедура ФайлНачалоВыбора(Элемент,ДанныеВыбора, СтандартнаяОбработка)
	СтандартнаяОбработка = ложь;
	Диалог = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
	Диалог.Фильтр = "Excel, *.xls*|*.xls*";
	Диалог.МножественныйВыбор=Ложь;
	Если Диалог.Выбрать() Тогда
		объект.Файл = Диалог.ПолноеИмяФайла;
	КонецЕсли;
КонецПроцедуры
7

Скачать файлы

Наименование Файл Версия Размер
Конвертация Exel файла в MXL (толстый клиент) 8.3.10 и выше
.epf 6,56Kb
21.05.19
3
.epf 6,56Kb 3 Скачать
Конвертация Exel файла в MXL (Тонкий клиент, Управляемая форма) 8.3.10 и выше
.epf 6,37Kb
21.05.19
4
.epf 6,37Kb 4 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. VPanin56 27 22.05.19 08:59 Сейчас в теме
2. fancy 22.05.19 09:54 Сейчас в теме
1) А просто открыть xls файл в 1С и потом сохранить как mxl религия не позволяет?

2) а этот код что жизненоважного делает?


&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
КонецПроцедуры
A_Max; plevakin; +2 Ответить
3. ogidni 22.05.19 10:01 Сейчас в теме
1. По вопросам религии не могу сказать, дабы чувства не задеть.
Excel не может сохраняться в mxl
2. Это лишний программный код - который кушать не просит.
4. AlexCherdakov 15 22.05.19 11:35 Сейчас в теме
(3)
Excel не может сохраняться в mxl
а у меня может, странно правда?
5. ogidni 22.05.19 18:41 Сейчас в теме
(4)
Excel не может сохраняться в mxl

поздравляю
6. VPanin56 27 23.05.19 07:42 Сейчас в теме
(4) Мой Excel кстати тоже не может сохранять в mxl.
Вопрос , что у тебя за уникальный Эхель?
7. AlexCherdakov 15 23.05.19 08:28 Сейчас в теме
ты выпал из контекста смотри выше
1) А просто открыть xls файл в 1С и потом сохранить как mxl религия не позволяет?

(6)
8. A_Max 17 23.05.19 12:47 Сейчас в теме
(3) 1. Зато 1С умеет в ПОЛЬЗОВАТЕЛЬСКОМ режиме (файл - открыть) замечательно открывать файлы excel и сохранять в кучу форматов.

2. Иииии? Может стоит откорректировать публикацию?
9. ogidni 23.05.19 14:11 Сейчас в теме
Оставьте свое сообщение