Консоль запросов + ТЗ как параметры

Публикация № 78001

Разработка - Инструментарий разработчика - Консоль запросов

43
Стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров. Совместима с настройками базовой консоли. Упрощает отладку запросов, использующих временные таблицы.

Ничего сверхестественного - стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров, включающая в себя возможность получения данных временных таблиц под отладчиком в качестве парамеров.

___________

14.05.2019

Добавлена возможность импорта файла, сохраненного при серверном выполнении.

Добавлена закладка "Промежуточные результаты". Позволяет выполнить запрос через функцию  Запрос.ВыполнитьПакетСПромежуточнымиДанными() и вывести данные сложного запроса в виде массива результатов.

 

result_array

 

Упрощена функция получения параметров таблиц в связи с расширением платформенных возможностей по анализу содержимого менеджера временных таблиц.

 

 

Функция АСТ_Сохранить(ТЗ, ИмяФайла = "", Опция = Неопределено) Экспорт
    // создана для удобства переноса таблиц или запросов в консоль запросов - скидывает тз во внешний файл, который можно вычитать консолью запросов
    ЗаписьXML = Новый ЗаписьXML;
    Если ПустаяСтрока(ИмяФайла) Тогда
        ИмяФайла = КаталогВременныхФайлов() + ?(ТипЗнч(ТЗ) = Тип("ТаблицаЗначений"), "copytz.xml", "copyreq.xml") ;
    КонецЕсли;
    Если ТипЗнч(ТЗ) = Тип("Запрос") Тогда
        
        Зн = Новый Структура("Текст, Параметры", ТЗ.Текст, ТЗ.Параметры);
        МассивТаблиц = Новый Массив;

        Если ТипЗнч(Опция) = Тип("Строка") Тогда
            ////////// если опция - строка - значит считаем что передается точный перечень таблиц   
            // прямой перечень таблиц уже не нужен - но оставим если вдруг нежелательно все содержимое менеджера тащить 
            Вр = СокрЛП(Опция);
            Пока СтрНайти(Вр, ",") > 0 Цикл
                Имя = СокрЛП(Лев(Вр,СтрНайти(Вр, ",") - 1));
                Если СтрДлина(Имя) > 0 Тогда
                    МассивТаблиц.Добавить(Имя);
                КонецЕсли;
                Вр = СокрЛП(Сред(Вр, СтрНайти(Вр, ",") + 1));
            КонецЦикла;
            Если СтрДлина(Вр) > 0 Тогда
                МассивТаблиц.Добавить(Вр);
            КонецЕсли;
        ИначеЕсли ТЗ.МенеджерВременныхТаблиц <> Неопределено Тогда //Если Опция = Истина Тогда
            Для каждого Вр из ТЗ.МенеджерВременныхТаблиц.Таблицы Цикл
                МассивТаблиц.Добавить(Вр.ПолноеИмя);
            КонецЦикла;
            // любое другое значение позволяет просто вытащить запрос без временных таблиц 
        КонецЕсли;
        
        // пробуем вытащить значения в параметры
        Для каждого Тб из  МассивТаблиц Цикл
            ТЗВрем = ТЗ.МенеджерВременныхТаблиц.Таблицы.Найти(Тб);
            Если ТЗВрем <> Неопределено Тогда
                Зн.Параметры.Вставить(Тб, ТЗВрем.ПолучитьДанные().Выгрузить());
                Т = "// '" + Тб  + "' таблица вытащена из менеджера временных таблиц и помещена как параметр"  + Символы.ПС;;
                Т = Т + "ВЫБРАТЬ " ;
                Для каждого Кол из Зн.Параметры[Тб].Колонки Цикл
                    Т = Т + Символы.ПС + Символы.Таб + Тб + "." + Кол.Имя + " КАК " + Кол.Имя + "," ;
                КОнецЦикла;
                Т  = Лев(Т, СтрДлина(Т) - 1);
                Т = Т + Символы.ПС + "ПОМЕСТИТЬ " + Тб ;
                Т = Т + Символы.ПС + "ИЗ" + Символы.ПС + Символы.Таб + "&" + Тб + " КАК " + Тб + Символы.ПС + ";" + Символы.ПС + "//////////////////////////////////////////////////////////" + Символы.ПС+ Символы.ПС;
                
                Зн.Текст = Т + Зн.Текст; 
                
            КонецЕсли;
        КонецЦикла;
        
        
    ИначеЕсли ТипЗнч(ТЗ) = Тип("МакетКомпоновкиДанных") Тогда
        Запрос = Новый Запрос;
        Для каждого Параметр из ТЗ.ЗначенияПараметров Цикл
            ЗначПарам = Неопределено;
            Если ТипЗнч(Параметр.Значение) = Тип("СписокЗначений") Тогда
                ЗначПарам = Новый СписокЗначений;
                ЗначПарам.ЗагрузитьЗначения(Параметр.Значение.ВыгрузитьЗначения());
            Иначе
                ЗначПарам = Параметр.Значение;
            КонецЕсли;
            Запрос.УстановитьПараметр(Параметр.Имя,ЗначПарам);
        КонецЦикла;
        
        // определимся с набором
        Если ТипЗнч(Опция) <> Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
            // набор явно не указан - пробуем подобрать первый попавшийся набор запрос
            Для каждого Нб из ТЗ.НаборыДанных Цикл
                Если ТипЗнч(Нб) = Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
                    Опция = Нб;
                    Прервать;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
        
        Если ТипЗнч(Опция) = Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
            Запрос.Текст = Опция.Запрос;
            Для каждого Параметр из Опция.ЗначенияПараметров Цикл
                ЗначПарам = Неопределено;
                Если ТипЗнч(Параметр.Значение) = Тип("СписокЗначений") Тогда
                    ЗначПарам = Новый СписокЗначений;
                    ЗначПарам.ЗагрузитьЗначения(Параметр.Значение.ВыгрузитьЗначения());
                Иначе
                    ЗначПарам = Параметр.Значение;
                КонецЕсли;
                Запрос.УстановитьПараметр(Параметр.Имя,ЗначПарам);
            КонецЦикла;
        КонецЕсли;
        Зн = Новый Структура("Текст, Параметры", Запрос.Текст, Запрос.Параметры);
    Иначе
        Зн = ТЗ;    
    КонецЕсли;
    ЗаписьXML.ОткрытьФайл(ИмяФайла, "UTF-8");
    
    #Если Не ТонкийКлиент И НЕ ВебКлиент Тогда
        СериализаторXDTO.ЗаписатьXML(ЗаписьXML, Новый ХранилищеЗначения(Зн ,Новый СжатиеДанных(9)));
    #КонецЕсли
    
    ЗаписьXML.Закрыть();
    Возврат Истина;
КонецФункции

 


03.09.2015

В функции получения запроса в режиме отладки добавлена возможность автоматического определения используемых временных таблиц (переданных через менеджер запросов) и помещения их значений в соответствующий параметр.

Для определения состава временных таблиц осуществляются попытки выполнить запрос, с последующим анализом ошибки (в случае системных сообщений платформы на отличном от русского языка - требуется внести соответствующую правку в текст функции).

Также стоит учитывать, что в процессе автоматического анализа будет запрос будет единожды выполнен. Если само по себе выполнение запроса вызывает проблемы (зависает / либо слишком долго), используйте явное указание списка необходимых временных таблиц.

 

Получение запроса со временными таблицыми под отладчиком

15.11.2013

Данная редакция функции сохранения под отладчиком расширяет возможность отладки сложных запросов, использующих таблицы из менеджеры временных таблиц - в качестве третьего параметра позволяет указывать имена временных таблиц (через запятую), используемых в запросе. Содержимое временных таблиц которых при этом  будет вычитано из менеджера и использовано как параметр-таблица значений.

В качестве экзотического дополнения,  можно указывать МакетКомпоновкиДанных как источник запроса. В этом случае будет запрос будет извлечен из первого набора данных макета, либо можно указать конкретный набор в качестве третьего параметра.

15.11.10/2 Можно использовать результаты выполнения запроса как основание для создания структуры ТЗ и заполнения данными.


23.11.11/1 Добавлена возможность выгружать таблицы в файл / из файла.

10.04.11/1 Добавлена возможность выгружать запросы с параметрами (в т.ч. таблицы значений) в файл / из файла


Для выгрузки таблиц/запросов из конфигуратора в режиме отладки добавьте и используйте функцию

Функция EWG_Сохранить(ТЗ, ИмяФайла = "") Экспорт
    ЗаписьXML = Новый ЗаписьXML;
    Если ПустаяСтрока(ИмяФайла) Тогда
        ИмяФайла = КаталогВременныхФайлов() + ?(ТипЗнч(ТЗ) = Тип("Запрос"), "copyreq.xml", "copytz.xml") ;
    КонецЕсли;
    Зн = ?(ТипЗнч(ТЗ) = Тип("Запрос"), Новый Структура("Текст, Параметры", ТЗ.Текст, ТЗ.Параметры), ТЗ);
    ЗаписьXML.ОткрытьФайл(ИмяФайла, "UTF-8");
    СериализаторXDTO.ЗаписатьXML(ЗаписьXML, Новый ХранилищеЗначения(Зн ,Новый СжатиеДанных(9)));
    ЗаписьXML.Закрыть();
    Возврат Истина;
КонецФункции


 

Примеры обращения под отладчиком  :

EWG_Сохранить(НекийЗапрос.Выполнить().Выгрузить()); // будет выгружена таблица результатов запроса

EWG_Сохранить(НекийЗапрос); // будет выгружен текст запроса с параметрами и всеми используемыми временными таблицами

EWG_Сохранить(НекийЗапрос,, "ВТКонтрагенты, ВТДокументы"); // будет выгружен текст запроса с параметрами плюс времененные таблицы, соответствующие указанным.

 

 

Таблицы в консоль подгружаются через выбор пункта меню консоли "Импорт из файла по-умолчанию" на закладке ТЗ-параметры.

Запросы подгружаются через выбор пункта меню консоли "Импорт из файла по-умолчанию" на основной панели формы, либо через контекстное меню дерева запросов.

 

28.08.12 Мелкие косметические изменения в т.ч. вывод количество строк результата выполнения запроса.

 

43

Скачать файлы

Наименование Файл Версия Размер
Консоль для 8.3
.epf 106,32Kb
14.05.19
427
.epf 070213 106,32Kb 427 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. fierylions 05.02.11 09:30 Сейчас в теме
а как её запустить если в самом конфигураторе то просто код показывает если в предприятии то пустое окошечко
2. vec435 15 11.04.12 10:15 Сейчас в теме
при отладке из конфигуратора тз выгружается как отдельный файл или добавляется в параметры?
3. Kashemir 348 11.04.12 11:54 Сейчас в теме
Выгружается в отдельный файл, который можно загрузить в консоли как значение параметра
8. Bukaska 130 15.11.13 14:24 Сейчас в теме
(3) Это консоль для обычного приложения?(ТолстыйКлиент) или для управляемого приложения?(Тонкий клиент)
А то для обычного приложения я как то скачивала консоль: только загрузил запрос - консоль уже создала параметры, остается только ввести значения.
Вот бы для тонкого клиента что-нить такое.. А то другой раз запросы как простыня, чекнешься параметры искать)
9. Kashemir 348 15.11.13 14:34 Сейчас в теме
(8) Bukaska, для толстого клиента.
4. pvlunegov 142 20.04.12 11:28 Сейчас в теме
Спасибо автору за замечательную возможность работы с Таблицами Значений в качестве параметра запроса.
Единственная обработка (консоль запросов) на данном сайте, в которой ПОЛНОСТЬЮ реализована данная функция.

Есть даже сохранение ТЗ в файл запросов. Это просто замечательно!

Смотрел аналогичные консоли, там этой функции или нет, или урезанная, или атрофированная, или без сохранения таблицы в файл запросов.

Всем, кому надо работать с ТЗ и сохранять запросы в файл - рекомендую!
5. MakcTLT63 9 15.11.13 08:51 Сейчас в теме
Глянул скрины. У меня эта обработка хранится под именем EWG_Консользапросов.
Автор позаимствовал идею?
6. Kashemir 348 15.11.13 12:21 Сейчас в теме
(5) MakcTLT63, EWG это аббревиатура мой текущей фирмы. Идея и реализация собственная.
7. MakcTLT63 9 15.11.13 14:20 Сейчас в теме
(6)
Упс.. Прошу прощения за необоснованные подозрения.
Обработка лучшая.
Когда надо поработать с ТЗ она просто незаменима.
10. Kashemir 348 15.11.13 14:41 Сейчас в теме
(7) MakcTLT63, Приятно, что кому-то пригодилась :)
11. desarz 62 05.12.13 15:33 Сейчас в теме
12. sick_russian 05.02.14 06:25 Сейчас в теме
на скрине видно что колонке присваивается тип "СправочникСсылка.Номенклатура", а я такой тип выбрать не могу( почему?
13. Kashemir 348 10.02.14 19:37 Сейчас в теме
Подозреваю что в используемой конфигурации нет справочника "Номенклатура" :)
14. Nebiros777 5 25.02.14 13:31 Сейчас в теме
Удобная штука, постоянно подобной пользуюсь.
15. CaptainMorgan 14.03.14 12:58 Сейчас в теме
А вариант с управляемой формой возможен?
16. oyeah 14.01.15 02:35 Сейчас в теме
(15) CaptainMorgan, Вариант для УФ на диске ИТС RequestConsoleManaged\ИнструментыРазработчикаКонсольЗапросов­83.epf
17. premierex 08.04.15 14:25 Сейчас в теме
Не работает с параметром типа "Список значений", выдаёт ошибку "{(1,1)}: Переменная не определена (Прочее)
<<?>>Прочее", где "Прочее" - элемент справочника, заданного в параметре типа "Список значений". Да и сам подбор в список очень уж неудобно организован: тип выбирается из длинного выпадающего меню. Пока до самого низа его прокрутишь, чтобы необходимый тип выбрать, уже и желание пропадает этой консолью пользоваться.
18. unichkin 1198 03.09.15 21:33 Сейчас в теме
19. Kashemir 348 04.09.15 10:53 Сейчас в теме
(18) unichkin, Безусловно - но не всегда космический корабль удобнее автомобиля.
20. user645364_roman_sh 10.06.18 18:05 Сейчас в теме
Вот здесь выполняется запрос ОтладочныйЗапрос, для которого нет никаких параметров кроме параметров типа таблица значений.
Попытка
ОтладочныйЗапрос.Выполнить();
Исключение
ТекстОшибки = ОписаниеОшибки();
Продолжить;
КонецПопытки;

Почему не копируются параметры сразу? Например после строк

ОтладочныйЗапрос.Текст = ТЗ.Текст;
//по идее должны следовать строки
Для Каждого ЭлементСтруктуры Из Зн.Параметры Цикл
ОтладочныйЗапрос.Параметры.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
КонецЦикла;
22. Kashemir 348 21.06.18 03:55 Сейчас в теме
(20) Параметры так и копируются. Через попытку вытягиваются обращения ко временным таблицам. Альтернативой может служит только полноценный синтаксический анализатор, но даже он не сможет типизировать данные временные таблицы.
По мере получения ошибок при обращениях к данным временным таблицам появляется возможность изнать их имена, после чего можно через * выгрузить их из менеджера со всеми типизациями определенными для них в термах 1С.
21. user645364_roman_sh 10.06.18 18:28 Сейчас в теме
Второе замечание касается случаев когда МенеджерВременныхТаблиц запроса ТЗ содержит временные таблицы со значениями полей Неопределено или Null. Тогда начинает ругаться что при выполнении запроса ОтладочныйЗапрос эти его поля нетипизированные. Здесь может помочь вариант их к-л массово типизировать. Я в этом случае таким полям до использования функции EWG_Сохранить присвоил пустые ссылки в запросе используя Значение(справочник. и т.д...Понимаю некорректно, но по-другому не придумал.
23. Kashemir 348 21.06.18 04:00 Сейчас в теме
24. RailMen 783 11.09.18 19:06 Сейчас в теме
Допилил консольку так: сделал кнопку "Загрузить таблицу из excel". При загрузке из excel автоматом задаются типы колонок.

Прикрепленные файлы:
EWG_Консользапросов (Консоль запросов + ТЗ как параметры 8.2) 2.epf
Оставьте свое сообщение

См. также

Консоль запросов с перехватом отчетов СКД и запросов 12

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::Запросы v8::СКД 1cv8.cf Россия Абонемент ($m) Консоль запросов

Доработанная консоль запросов с автоматическим заполнением текста запроса и всех параметров на основании объекта Запрос, полученного в "Конфигураторе" или перехваченного встроенного/внешнего отчёта СКД.

2 стартмани

29.09.2019    1153    5    strek_ivan    3       

Консоль запросов с возможностью сравнения данных между базами (управляемые формы) 17

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Данная консоль позволяет сравнивать любые данные полученные произвольными запросами между текущей базой и внешней базой данных как файловой, так и клиент-серверной.

2 стартмани

26.08.2019    1209    14    Dadriel619960    9       

Встраиваем консоль запросов для отбора в стандартные обработки 1С 10

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Данное руководство поможет встроить форму отбора в стандартные обработки 1С, например "Групповое изменение реквизитов" или "Поиск и удаление дублей". Бывает случаи, что нужно сделать сложный отбор элементов, который невозможно реализовать через стандартный отбор или, в случае поиска и удаления дублей, справочник имеет тысячи элементов и поиск по нему дублей может знять даже не один день. Тут на помощь приходит консоль запросов, которая встраивается в обработки и помогает отобрать нужные элементы для дальнейших с ними действий.

1 стартмани

01.03.2019    2138    2    w.r.    3       

Консоль запросов с их сохранением в базе 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Казахстан Абонемент ($m) Консоль запросов

Консоль запросов стандартная, предназначена для создания и выполнения запросов в режиме предприятия с помощью конструктора запросов или вручную. Долгое время использовал эту стандартную консоль запросов и даже научил нескольких бухгалтеров пользоваться ею, и понял, что основное неудобство - это хранение запросов во внешних файлах, когда копии запросов расползаются по рабочим столам, и бухгалтера (да и я ) должны помнить, где лежит последняя версия запроса. И тогда мне пришла мысль хранить их в самой базе, что я и реализовал. При этом возможности штатного сохранения\чтения в/из внешних файлов осталась неизменной.

1 стартмани

26.02.2019    1743    makfromkz    9       

Консоль запросов (управляемые формы) + возможность работы в толстом клиенте 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Одна обработка для Толстого и тонкого клиента. Работает как на управляемых, так и не управляемых формах. Заброс получился большой и громоздкий - ГДЕ ТОРМОЗИТ? Нужно писать в консоли для обработки и часть параметров не используется? 1С зависла при выполнения запроса и текст запроса потерян, а авто сохранение не любите, т.к. он при ошибке не оставляет вам вариантов - ошибка уже вписалась?! Тестируете обработку Табличных Частей документа? Толстый клиент проверен на 8.2.19.130, Управл. формы на 8.3.10.2580. УФ Оптимизация под такси, но нормально под простой интерфейс.

1 стартмани

17.01.2019    2146    7    Sevg    0       

Выгрузка запроса из отладки в консоль запросов (Управляемые формы) 5

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Помощник в отладке и доработке запросов использующих менеджер временных таблиц.

1 стартмани

13.11.2018    3493    4    redtram    2       

Консоль запросов для управляемых форм 8.3 18

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Универсальная внешняя обработка (СДРКонсольЗапросовХ) для создания, редактирования и отладки запросов, с возможностью обработки таблицы результатов произвольными алгоритмами на языке 1С. Выгрузка результатов запроса в таблицу или дерево значений, включая временные таблицы и запросы пакета. Формирование запроса для консоли в отладчике, включая временные таблицы и параметры. Версия 1.1.0.39 от 01.10.2019

3 стартмани

08.11.2018    6504    61    ROL32    8       

Управляемая консоль запросов, отчетов 3.7.3 (расширение, внешняя обработка) 355

Инструменты и обработки Программист Архив с данными v8 v8::УФ v8::Запросы v8::СКД 1cv8.cf Абонемент ($m) Консоль запросов

Работа с запросом и СКД, Полная поддержка пакетных запросов, временных таблиц, Выполнение в фоне (с возможностью отмены), Сравнение результатов, текстов, Разбор структуры запроса в виде дерева, Анализ плана запроса, Групповая обработка

1 стартмани

14.08.2018    48283    1077    Evg-Lylyk    409       

Консоль запросов 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Консоль запросов для УФ. Внешне похожа на консоль для обычного приложения. Но есть ряд новых возможностей.

1 стартмани

25.06.2018    5940    16    17808849    10       

Консоль HTTP-запросов с генерацией кода 164

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Консоль запросов

Консоль HTTP-запросов, которая не только выполняет запросы и получает результат их выполнения, но и генерирует необходимый код. Использую на 8.3.11.2899.

1 стартмани

25.05.2018    14761    215    leongl    15       

Униформальная консоль запросов 107

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Минималистичная и функциональная консоль запросов, которая выглядит и работает одинаково, как в обычных формах, так и в управляемых.

1 стартмани

23.05.2018    16463    273    Synoecium    50       

Групповая обработка реквизитов + консоль запросов 13

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ v8::Запросы Розница УНФ БП3.0 УТ11 КА2 Абонемент ($m) Консоль запросов

Расширение конфигурации, которое в типовую обработку "Групповое изменение реквизитов" добавляет возможность отбирать объекты для обработки запросом. Необходимо наличие обработки "Консоль запросов" с ИТС.

2 стартмани

20.03.2018    11693    41    Kutuzov    6       

Консоль запросов со встроенным Конструктором запросов для 1с8.3 (8.2) своими руками 12

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Мы можем сами создать свою консоль запросов - именно такую, которая подходит для наших нужд. Кроме того, создав собственную Консоль запросов, Вы не только получаете удобный для себя инструмент, а также получаете навык программирования в среде 1с8, что очень полезно будет начинающим программистам 1С.

1 стартмани

21.12.2017    15262    51    jan-pechka    23       

Консоль запросов: работа с временными таблицами 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Консоль запросов помогает сэкономить время при работе со сложными запросами со временными таблицами.

1 стартмани

12.12.2017    5976    9    lapa_kn    1       

Консоль запросов OData 15

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Консоль запросов по протоколу OData.

1 стартмани

30.08.2017    13559    66    vlsv    6       

Консоль запросов 8.3 (обычное приложение) с возможностью переноса параметров запроса через строку (из отладки). А также с возможностью очень быстрой выгрузки больших объемов данных в Excel(CSV) исключительно мощностями сервера 11

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Казахстан Абонемент ($m) Консоль запросов

Доработанная консоль запросов для 1С 8.3. Доработанные функции: 1. Загрузка параметров запроса из строки, полученной в отладке методом ЗначениеВСтрокуВнутр(Запрос.Параметры) 2. Выгрузка результата запроса в CSV файл на сервере и передача его на клиент. Быстрее в 10 раз чем стандартное "Сохранить Как" 3. Получение на основание запроса кода для выполнения обработки. При этом в коде уже прописаны все установленные для запроса параметры, а так же типизировано основное поле результата. 4. Конвертация текста запроса из вложенных запросов, во временные таблицы

1 стартмани

09.07.2017    9892    28    matveev.andrey.v    0       

Консоль запросов с графом (Анализатор сложных запросов) 340

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов для анализа запросов с большим количеством временных таблиц и вложенных запросов. Отображает структуру взаимосвязей временных таблиц в виде графа. Позволяет быстро передвигаться по тексту запроса и получать результат выполнения подзапросов. Единственная консоль запросов, которая позволяет выводить результат выполнения вложенных запросов и любой части объединения запроса. Удобное получение данных запроса из отладчика включая временные таблицы. Текст запроса в структурированном виде (можно свернуть, развернуть текст подзапроса). И еще много другого, чего вы не найдете в других консолях запросов. Поддержка УФ и ОФ. Версия 0.9 от 03.07.2019 (поддержка WebKit).

10 стартмани

03.05.2017    85744    373    manuel    219       

Консоль запросов 1С 8 / SQL (версия 5.3.42) 18

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Беларусь Абонемент ($m) Консоль запросов

Обработка Консоль запросов 1С 8 / SQL предназначена для создания и выполнения запросов в режиме управляемого приложения к информационным базам 1С 8 и базам данных SQL.

1 стартмани

27.02.2017    15608    67    sertak    26       

Консоль запросов EX (внешние данные) 14

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Работа с внешними данными в консоли запросов (1С 7.7, 8.x, XBase, Excel, ADO)

1 стартмани

30.10.2016    5173    25    Cерый    0       

Консоль запросов SQL 11

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Иногда возникает желание посмотреть, как информация 1С уложена в базе данных. Данная обработка позволяет показать структуру базы данных, а так же обычными SQL-запросами просмотреть содержимое таблиц MsSQL.

1 стартмани

21.10.2016    7127    43    igel9780    8       

"Консоль запросов" с возможностью вывода UID справочников и документов 0

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Доработанная обработка "Консоль запросов" с возможностью вывода UID справочников и документов.

10 стартмани

11.07.2016    4091    6    graysvd    4       

Консоль запросов для больших баз данных (БД) 30

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Самая обычная консоль запросов для толстого клиента, но обладающая некоторыми специальными возможностями для отладки и сверки сложных запросов, которые выбирают большие объёмы данных. А именно: -Сохранение результата запроса в файл; -Возможность выборки из сохраненного файла; -Замеры времени выполнения отдельных временных таблиц в запросе; -Подготовка текста запроса к помещению в модуль; -Проверка запроса на не уничтоженные временные таблицы;

1 стартмани

28.06.2016    8152    21    ixilimuse    9       

Консоль запросов "Запросник" для управляемых форм с подсветкой синтаксиса 35

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Вот уже много лет я использую замечательный инструмент для работы с запросами - Запросник. Однако, с переходом на управляемые формы для его использования пришлось запускать базы в устаревшем толстом клиенте, да еще и разрешать в свойствах конфигурации использование обычных форм. В 2014 году появился запросник на управляемых формах, который, к сожалению, оказался несовершенен из за ограничений платформы. Самое неприятное из них - отсутствие подсветки синтаксиса. Мне кажется, что я нашел решение этой проблемы.

1 стартмани

19.04.2016    30731    263    1С_Мастер    42       

Доработанная консоль запросов 1С 8.3 32

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

После многих дней доработок, консоль стала более совершенной. Поменялся интерфейс, добавились новые возможности.

1 стартмани

28.03.2016    14365    127    Раис910    10       

Консоль запросов для УФ с подсветкой синтаксиса и обработкой результата 119

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Самая быстрая консоль запросов для управляемых форм с подсветкой синтаксиса и обработкой результата

1 стартмани

08.01.2016    28106    488    BurningChrome    81       

Консоль запросов для управляемого приложения с возможностью вывода в таблицу значений 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Часто при отладке запросов на базах с большим объемом информации возникают ситуации, когда вывод большого количества строк результатов запроса в табличный документ занимает много времени. Представленная обработка позволяет выводить результат запроса в таблицу значений, что практически исключает время ожидания результата.

1 стартмани

20.11.2015    5577    14    merabn    11       

ADO Консоль запросов с конструктором для управляемого приложения (8.3.6+) 124

Инструменты и обработки Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Обработка "Консоль запросов" для управляемого приложения с возможностью строить запросы к внешним источникам данных по интерфейсу ADO. Имеет встроенный конструктор запросов с типовым интерфейсом для управляемого приложения. В одном пакете можно обращаться к нескольким внешним источникам. В результате ADO запроса можно получить как обычную выборку данных, так и ВременнуюТаблицу, которую можно использовать в других запросах 1С или в контексте ADO... Управляемые формы, платформа не ниже 8.3.6.

1 стартмани

13.11.2015    19279    231    DC    41       

Exec - Выполнение кода, консоль запросов и не только! 70

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Незаменимый инструмент администратора БД и программиста: Выполняйте произвольный код из режима 1С Предприятие; сохраняйте/загружайте часто используемые скрипты; выполняйте запросы с замером производительности запроса в целом и каждой из временных таблиц в частности, а также с просмотром содержимого временных таблиц; произвольным образом изменяйте любые объекты БД, редактируя даже не вынесенные на формы реквизиты и записывая изменения в режиме "ОбменДанными.Загрузка = Истина"; легко узнавайте ИД объектов БД; выполняйте прямые запросы к SQL с замером производительности и не только!

5 стартмани

10.11.2015    35629    173    catsam    11       

Консоль запросов с временными таблицами 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Предназначена для отладки запросов с временными таблицами. На базе обработки с ИТС (обычное приложение). Похожа на разработку http://infostart.ru/public/19577/, но предлагает более простой сценарий использования.

1 стартмани

30.09.2015    9722    13    Mleg    9       

Консоль запросов RLS 56

Инструменты и обработки Программист Приложение (exe) v8 Windows Абонемент ($m) Консоль запросов

Поставка включает в себя конфигурацию, внешнюю обработку и файл описания в формате pdf (приведенный ниже). Консоль можно использовать при анализе текста запроса RLS, который будет выполнен к данным под конкретным пользователем.

1 стартмани

22.08.2015    13026    68    Rioneri    16       

Консоль запросов (Такси) 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов для технологических платформ версии 8.3 адаптированная для интерфейса "Такси".

1 стартмани

10.07.2015    8785    54    vdusaev    10       

Консоль запросов продвинутая 8.3 (с возможностью обработки результата запроса) 23

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

В 8.2 был очень удобный инструмент для выборки данных запросом и их обработки с помощью кода. Нечто подобное теперь можно сделать и в 8.3. Обработка открывает конструктор запросов в тонком клиенте, позволяет вывести результат в виде списка или дерева, обработать полученный результат нужным Вам образом с помощью кода, получить замер времени выполнения запросов, хранить тексты запросов в удобной форме, выводить GUID'ы ссылок.

1 стартмани

25.06.2015    10121    222    zyama    16       

Консоль запросов для обычного приложения с расширенным функционалом 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Консоль запросов с удобным просмотром временных таблиц, сортировкой и отбором строк как во временных таблицах, так и в результате запроса.

1 стартмани

19.05.2015    2941    22    Kharcha    2       

Простейшая консоль ADO-запросов 7

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Данная обработка пригодится, если вам надо быстро проверить работоспособность и результат запроса или хранимой процедуры во внешней базе данных.

1 стартмани

08.04.2015    12479    21    Synoecium    6       

Универсальный подбор и обработка объекта + Консоль запросов 12

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Доработанная универсальная обработка "Универсальный подбор и обработка объекта" с возможностью отбирать данные по запросу и обработкой регистров сведений.

1 стартмани

27.03.2015    8561    48    vowg    6       

Консоль запросов для УФ универсальная 8.3.7.3 693

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Реализован программный вызов консоли для захвата "рваного" запроса, МВТ и параметров. В консоли реализована полная поддержка работы с таблицами значений. Выборочный просмотр пакетов и временных таблиц. Возможность выборочной выгрузки пакета запроса в ТЗ, с последующим её редактированием, сохранением на диск. Использование сохранённой ТЗ в качестве параметра для других запросов. Возможность обхода ТЗ в цикле с выполнением кода. Отсутствуют ошибки при наличии уничтожения временных таблиц. Замер времени выполнения каждого пакета запроса. Приличное окно настройки типа (только для параметров запроса), лёгкое преобразование в список значений и обратно. Поддержка дополнительных типов: ТЗ, Граница, Момент времени, Вид счёта, Вид движения и т.д. Форматирование типа значения при выводе запроса (NULL, пустая ссылка, пустая строка и т.п.). Наверное, самый лучший подбор ширины колонок. Возможность добавлять листы для вывода результатов запросов. Генерируется текст для конфигуратора с учётом количества результирующих пакетов, для каждого пакета можно настроить выборку или выгрузку и пересоздать текст.... Короче, лучше один раз увидеть ...

5 стартмани

12.03.2015    122679    3987    akor77    686       

Консоль запросов 8.3 @AlexxSys 154

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов 8.3 - это более продвинутая версия консоли запросов, как по функциям, так и по интерфейсу. Имеет полностью переработанный интерфейс, с более понятным расположением панелей кнопок. Также добавлен нужный функционал - структура конфигурации, с возможностью добавления в запрос таблиц и полей и справка по синтаксису запросов.

1 стартмани

20.02.2015    23168    559    AlexxSys    107       

Простая консоль запросов для обычного и управляемого приложения 6

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Настоящая консоль запросов предназначена для разработки и отладки запросов. Работает в режимах: управляемое приложение и обычное приложение. Отличия от встроенной консоли (УТ, УПП,): 1) Возможность работы в управляемом приложении. 2) Возможность задавать в параметрах таблицы значений, списки значений, массивы, моменты времени. 3) Более удобное нахождение ошибок. 4) Вывод в таблицу значений. 5) Возможность перевести результат в параметр. 6) Быстро загружать и сохранять текст запроса и параметры. 7) Замер времени исполнения.

1 стартмани

17.02.2015    4617    32    BalyunovVV    19       

Консоль запросов для управляемого приложения для запуска в "1С:Предприятии" 8.2 с планом выполнения запроса 11

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Обработка представляет собой "ремейк" консоли запросов с диска ИТС для управляемого приложения для запуска в "1С:Предприятии" 8.3 с планом выполнения запроса.

2 стартмани

07.02.2015    12002    63    cargobird    4       

Консоль запросов 1с 8.2 для отладки больших запросов с множеством временных таблиц (толстый клиент) 11

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Собственно обычная консоль, в которую добавлены 2 инструмента: 1. Показывать список временных таблиц запроса (закладка "таблицы"). Если кликнуть по наименованию временной таблицы, то курсор в теле запроса перейдет к ее определению. Также в теле запроса можно горячими клавишами переходить к определению временных таблиц. 2. Можно просматривать содержимое каждой временной таблицы Консолью так же удобно пользоваться и для небольших запросов :)

1 стартмани

03.02.2015    4959    114    tofff    5       

Консоль запросов к базе Oracle в 1С 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Консоль помогает проверить оракловский запрос из 1С, не используя PL/SQL developer.

1 стартмани

23.01.2015    5849    20    байт    2       

Консоль запросов для управляемых форм 6

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов для управляемого приложения с обработкой результата и выводом в табличный документ.

1 стартмани

14.12.2014    7383    46    mvsemenov    13       

Консоль запросов для тонкого клиента с просмотром временных таблиц и импортом запросов из конфигуратора 8

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Теперь можно в табло посмотреть произвольные ВТ, сделанные в других запросах и переданные через МенеджерВременныхТаблиц. И также посмотреть их в пользовательском режиме.

1 стартмани

28.11.2014    9846    36    Boris-Leleko    3       

Консоль запросов (обычное приложение) 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Обработка "Консоль запросов" предназначена для составления и исполнения запросов 1С:Предприятия 8.2. Данная обработка предназначена, в основном, для специалистов по внедрению и опытных пользователей.

1 стартмани

01.09.2014    5346    77    DISAoner    9       

Консоль запросов для управляемого приложения 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Полноценная консоль запросов для управляемого приложения с вызовом конструктора

1 стартмани

14.08.2014    3199    55    SmAlex    9       

КонЗап - консоль запросов с улучшенным интерфейсом и дополнительными функциями 16

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Консоль запросов (Платформа 8.х режим - обычное приложение) с улучшенным интерфейсом и дополнительными функциями (загрузка параметров запроса из файла, работа с временными таблицами, замер времени выполнения, групповая обработка результатов запроса). Часть функций позаимствованы из других обработок, часть разработаны "с нуля".

1 стартмани

16.07.2014    11726    108    serjpsv    18